This project is read-only.

S3Trio64 causes freezing?

Sep 28, 2008 at 8:45 PM
I am checking out Singularity for an academic project this semester (I just started on it today).

While tinkering with the apps and drivers, I wanted to try and use the S3 driver to get the slides app to work.
I used the following driver registration (from SlidesDistro.xml):
   <driver identity="S3Trio64" />
   <provides signature="/pci/06/01/10de/0050" name="NvPciLpc" />
   <follows  signature="/pci/02/00" name="NvPciLpc" />
   <follows  signature="/pci/01/01/10de" name="NvPciLpc" />
and I added the other slides as resources (as recommended by another discussion here somewhere).

But after i run "slides", I quickly see the numbers appearing and when the screen goes blank, the O/S stops. It seems to freeze, but my VirtualPC 2007 (64-bit on Vista btw) isn't actually doing anything, so my guess is it's waiting for something.

Anyone any ideas?

Sep 29, 2008 at 5:02 PM
Some more info:
It seems Singularity is pritty much up and running in the background. When I type "exit", the Virtual Machine stops after a few seconds, as it does whe you type "exit" and press enter at the shell...

So the problem is the graphics driver does not render the console anymore, but it is still running.
Is it possible that it needs to be closed somehow, and that slide crashes somewhere before it releases the display?

Any clues to how the display device works?
Is there a command that allows me to reinitialize the device driver from the shell?

PS: Tried it on 32-Bit VirtualPC, reacts about the same.