Unable to read the project file 'Hello.csproj'

Mar 8, 2008 at 5:01 PM
I get the following error when trying to open up a Singularity application with Microsoft Visual C# 2005 Express Edition:

C:\singularity-6709\bas\Targets\Paths.targets(67,63): The imported project "C:\singularity-6709\base\Targets\Ide.targets" was not found. Confirm that the path in the <Import> declaration is correct, and that the file exists on disk.

I want to open a simple app and make modification or create a new app. Appreciate any help.
Coordinator
Mar 17, 2008 at 9:09 PM
Please read:
<http://www.codeplex.com/singularity/Thread/View.aspx?ThreadId=23466>
you can use VS as a source editor but there is "no support" for project management in VS in this RDK V1.
it's easier to edit .CSPROJ and .PROJ files in notepad.
Mar 18, 2008 at 2:05 PM
VS is not "officially" supported, but it does work. You will need to run "setenv /vs" once, in order to create the Ide.targets file. After that, you can open some (but not all) Singularity projects using VS 2005. (They can be made to work in VS 2008 as well, but that's a separate topic.)

Please note that, because the Singularity environment (both runtime and build environment) are very different from Windows and the .Net Framework, many things will not work when editing projects using VS 2005. Specifically, Intellisense does not work, editing project references will not work, and editing some project properties will cause the VS project designer to change the project file in undesirable ways.

The VS support should be seen as a nice helper, but it should not be seen as a production-quality development experience. This may be addressed in some future version of the RDK, but there are no specific plans to do so right now.

Mar 22, 2008 at 1:51 PM
I've tryed to run setenv.cmd with the /vs switch. But he said, it's a unregognized option. What's wrong?

When I look into the file, there is no option like vs.
Coordinator
Mar 25, 2008 at 8:12 PM
Edited Mar 27, 2008 at 10:06 PM
sorry, we're on different ends of the twilight zone. the setenv /vs is slated for RDK 2.

but because we let the cougar out of the ziplock, let's try anyway.

THIS WILL NOT ALLOW YOU TO OPEN OR BUILD .PROJ FILES
just .CSPROJ files

0) try to open (as a PROJECT) ...\base\Applications\Hello\Hello.csproj in VS2005 and you'll get a dialog complaining that:
Unable to read the project file 'Hello.csproj'
...\base\Targets\Paths.targets(67,63): The imported project
"...\base\Targets\Ide.targets" was not found. blea blea. (OK)

1) notepad ...\base\createvstargets.cmd
2) paste text between ----------
----------
call setenv.cmd
:Temporarily disable delayed expansion so that the exclamation
:points (!'s) are not interpretted as variables
 
Coordinator
Mar 25, 2008 at 8:43 PM
oops. DON'T FORGET TO CHANGE THE BUILD TYPE FROM 'Debug' to 'Prototype' in VS 2005. or you won't see your changes.

wrong: observe updated 'Hello' files in ...\base.OBJ\Apps\Debug.x86.MarkSweep (Hello.xml,Hello.pdb,Hello.exe)
correct: observe updated 'Hello' files in ...\base.obj\Apps\Prototype.x86.MarkSweep (Hello.manifest,Hello.xml,Hello.pdb,Hello.exe)

the hint here is in your special RDK configured environment:
set BUILDTYPE
BUILDTYPE=Prototype
set Configuration
Configuration=Prototype

and to reiterate, for your changes to make it to the ISO or boot system, you still must go to ...\base and
msb Distro\World.proj
Coordinator
Mar 27, 2008 at 10:08 PM
Edited Mar 27, 2008 at 10:09 PM
had to update source for create_vs_targets.cmd in 5th (twilight zone) posting to defeat wiki mixup character interpretation. several times. be sure to use "Preview" tab every time